【UiPath】バージョンアップ(19.2.0)でまたもや動かなくなった

RPA
この記事は約3分で読めます。

とっちゃん@nyanco! です。

今回は、【UiPath】バージョンアップ(19.2.0)でまたもや動かなくなったというお話です。

RPA(Robotic Process Automation)アプリ、UiPathがまたまた動かなくなりました…
バッチファイル起動でも、です。

例によって、各バージョンが格納されているフォルダ[C:\Users\ユーザー名\AppData\Local\UiPath\]を見に行くと…
f:id:nyanco696:20190307212518j:plain:w400
はい、やはり新バージョン「19.2.0」が本日付で増えておりました。
他にも、「19.1.0」以外のバージョンの更新日時も変わってますね…。

試しにバッチファイル内のアプリバージョンを「19.1.0」から「19.2.0」に変更して実行してみるも、コマンドプロンプトの黒い画面は出るもののそれもすぐに閉じて何も起きず。

次にUiPathアプリを立ち上げてプロジェクトを開くと、特に読み込みエラーにはなってないのですが…
f:id:nyanco696:20190307212326p:plain:w400

実行すると「実行を開始できません」というエラーが。
f:id:nyanco696:20190307212944p:plain:w400

何やら難しいことが書いてますね…
f:id:nyanco696:20190307213126j:plain:w400

EndpointDispatcher で ContractFilter が一致していないため、Action ‘http://tempuri.org/IUiPathRemoteDuplexContract/SubscribeToEvents’ を含むメッセージを受信側で処理できません。この原因としては、送信側と受信側の間でコントラクト (送信側と受信側の Action の不一致) またはバインド/セキュリティが一致していないことが考えられます。送信側と受信側に同じコントラクトおよび同じバインド (Message、Transport、None などのセキュリティ要件を含む) があることを確認してください。

ああ、なんのことやらさっぱりです。。。

「uipath EndpointDispatcher で ContractFilter が一致していないため」とかでググってみるも解決できそうな記事は見受けられず…

とりあえず色々試してみた結果、バッチファイルを下記のように変更したら動くようになりました。

C:\Users\ユーザー名\AppData\Local\UiPath\app-19.1.0\UiRobot.exe /file “C:\プロジェクトファイルのパス\プロジェクト名.xaml”

C:\Users\ユーザー名\AppData\Local\UiPath\app-18.3.0\UiRobot.exe /file “C:\プロジェクトファイルのパス\プロジェクト名.xaml”

実行するUiPathのバージョンを最新ではなくかなり古いバージョンにしてみると動いた、という感じです。

相変わらずナゾですが、しばらくこれで様子を見ます。

今回は以上となります。
最後まで読んでいただきましてありがとうございました!
それではまた〜✧٩(ˊωˋ*)و✧

コメント